Yoast exploit impacts 17 Million WordPress websites

Unfortunately an exploit has been discovered in Yoast – a WordPress SEO plugin (and my personal favourite SEO plugin!)

Update your site immediately to Yoast version 7.4 or later  – as all prior versions are vulnerable. If your WordPress site is configured to allow auto-updates then the patch may have already been applied – but check now – better to be safe than sorry! Our Website Concierge clients can be assured their sites have already been updated.

Act now to be safe.

The reason you should act promptly is that the hacker community (bless their little black hearts) now know the details of this exploit and will be feverishly setting up their hacking software to take advantage of it to vandalise at least some of the 17 Million websites that have downloaded Yoast.

Read more: